/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.164
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.164 2014/02/23 16:08:24 pacho Exp $
4
5 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
6 amd64 stable, bug #500758
7
8 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
9 Fix ia64 where the order of the configure options was overridden by mips,
10 thanks Arfrever
11
12 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
13 Because sometimes portage is stupid
14
15 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
16 Fix dependence on spidermonkey for mips, bug #495168
17
18 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
19 Stable for sparc, wrt bug #484486
20
21 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
22 Stable for alpha, wrt bug #484486
23
24 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
25 Stable for ia64, wrt bug #484486
26
27 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
28 Stable for ppc64, wrt bug #484486
29
30 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
31 Stable for ppc, wrt bug #484486
32
33 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
34 Stable for arm, wrt bug #484486
35
36 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
37 Stable for x86, wrt bug #484486
38
39 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
40 Stable for amd64, wrt bug #484486
41
42 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
43 -files/polkit-0.110-CVE-2013-4288.patch:
44 old
45
46*polkit-0.112-r1 (19 Sep 2013)
47
48 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
49 polkit-0.112.ebuild:
50 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
51
52 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
53 Remove vulnerable version
54
55*polkit-0.110-r1 (19 Sep 2013)
56
57 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
58 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
59 Bump for CVE-2013-4288
60
61*polkit-0.112 (19 Sep 2013)
62
63 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
64 Bump for CVE-2013-4288
65
66 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
67 polkit-0.111-r1.ebuild:
68 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
69 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
70 always more about convinience than being strict requirement.
71
72 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
73 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
74 per ssuominen's approval
75
76 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
77 polkit-0.111-r1.ebuild:
78 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
79
80*polkit-0.111-r1 (08 Aug 2013)
81
82 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
83 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
84
85*polkit-0.111 (15 May 2013)
86
87 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
88 Version bump by "okias" from Freenode
89
90 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
91 -files/polkit-0.107-fallback.patch:
92 old
93
94 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
95 Stable for sh, wrt bug #452688
96
97 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
98 files/polkit-0.110-W_define.patch:
99 Include link to upstream bug.
100
101 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
102 +files/polkit-0.110-W_define.patch:
103 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
104 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
105
106 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
107 Stable for sparc, wrt bug #452688
108
109 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
110 Add s390 keywords #457078 by Michael Palimaka.
111
112 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
113 Stable for alpha, wrt bug #452688
114
115 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
116 Stable for ppc64, wrt bug #452688
117
118 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
119 Stable for ia64, wrt bug #452688
120
121 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
122 Stable for ppc, wrt bug #452688
123
124 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
125 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
126 errors as noted by _AxS_.
127
128 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
129 arm stable, bug #452688
130
131 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
132 x86 stable wrt #452688
133
134 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
135 amd64 stable wrt #452688
136
137 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
138 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
139 old
140
141*polkit-0.110 (11 Jan 2013)
142
143 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
144 Version bump.
145
146 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
147 polkit-0.109-r1.ebuild:
148 Add ~sh wrt #436668
149
150 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
151 Add ~ia64, wrt bug #436668
152
153 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
154 Stable for sparc, wrt bug #436666
155
156 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
157 Stable for alpha, wrt bug #436666
158
159 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
160 -polkit-0.109.ebuild:
161 old
162
163*polkit-0.109-r1 (21 Dec 2012)
164
165 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
166 +files/polkit-0.109-XAUTHORITY-fallback.patch:
167 Backport XAUTHORITY fallback support from upstream git.
168
169 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
170 Add ~ia64, wrt bug #436668
171
172*polkit-0.109 (19 Dec 2012)
173
174 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
175 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
176
177 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
178 Stable for ia64, wrt bug #436666
179
180 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
181 stable arm, bug #436666
182
183 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
184 old
185
186 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
187 stable ppc64, bug #436666
188
189 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
190 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
191 bug #436666
192
193 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
194 stable ppc, bug #436666, thanks peratu
195
196 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
197 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
198 but using sed to avoid eautoreconf) wrt #443798
199
200*polkit-0.108 (18 Nov 2012)
201
202 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
203 Version bump.
204
205 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
206 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
207 Drop ~x86-fbsd due to bug #439968.
208
209 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
210 polkit-0.107-r1.ebuild:
211 Drop HPPA keywording (bug #438368).
212
213 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
214 Set QA_MULTILIB_PATHS for bug #424423.
215
216 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
217 Marked ~hppa (bug #436668).
218
219 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
220 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
221 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
222 and emphatize it's an Portage issue instead of polkit issue in src_install()
223 message.
224
225 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
226 Stable for amd64, wrt bug #436666
227
228*polkit-0.107-r1 (20 Sep 2012)
229
230 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
231 +files/polkit-0.107-fallback.patch:
232 Introduce upstream patch for falling back to uid 0 for authentication if list
233 of admin identities is empty.
234
235 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
236 -polkit-0.106-r7.ebuild:
237 old
238
239*polkit-0.107 (13 Jul 2012)
240
241 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
242 Version bump.
243
244 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
245 -polkit-0.106-r6.ebuild:
246 old
247
248 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
249 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
250 #391865 by Maksim Melnikau
251
252*polkit-0.106-r7 (02 Jul 2012)
253
254 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
255 RESTRICT="multilib-strict" since it's not compatible with the whole
256 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
257 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
258
259*polkit-0.106-r6 (01 Jul 2012)
260
261 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
262 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
263 /usr/lib to /usr/lib64 symlink.
264
265 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
266 polkit-0.106-r5.ebuild:
267 Adding dependency on SELinux policykit module if USE=selinux is set
268
269 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
270 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
271 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
272
273 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
274 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
275 old
276
277*polkit-0.106-r5 (27 Jun 2012)
278
279 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
280 Revert entire unix-group:wheel experiment back to unix-user:0 because
281 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
282 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
283 by Doug Goldstein.
4 284
5*polkit-0.106-r4 (27 Jun 2012) 285*polkit-0.106-r4 (27 Jun 2012)
6 286
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 287 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 288 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 613 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 614 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 615 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 616 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 617 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.164

  ViewVC Help
Powered by ViewVC 1.1.20