/[gentoo-x86]/sys-auth/polkit/ChangeLog
Gentoo

Diff of /sys-auth/polkit/ChangeLog

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.89 Revision 1.190
1# ChangeLog for sys-auth/polkit 1# ChangeLog for sys-auth/polkit
2# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2 2# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.89 2012/06/27 10:06:14 ssuominen Exp $ 3# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit/ChangeLog,v 1.190 2015/01/14 18:29:42 mrueg Exp $
4
5 14 Jan 2015; Manuel Rüger <mrueg@gentoo.org> polkit-0.112-r2.ebuild:
6 Add dep on kde-plasma/polkit-kde-agent as suggested by Elias Probst. Fixes bug
7 #536550.
8
9 11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
10 Stable for ia64, wrt bug #525252
11
12 06 Nov 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r2.ebuild:
13 Don't run pax-mark when variable "m" is empty wrt #485910 by "Nikoli"
14
15 04 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
16 Stable for sparc, wrt bug #525252
17
18 03 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
19 Stable for x86, wrt bug #525252
20
21 02 Nov 2014; Sven Vermeulen <swift@gentoo.org> polkit-0.112-r2.ebuild:
22 Remove sec-policy/selinux-* dependency from DEPEND but keep in RDEPEND (bug
23 #527698)
24
25 02 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
26 Stable for alpha, wrt bug #525252
27
28 01 Nov 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
29 Stable for ppc, wrt bug #525252
30
31 31 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
32 Stable for ppc64, wrt bug #525252
33
34 30 Oct 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r2.ebuild:
35 Stable for amd64, wrt bug #525252
36
37 23 Oct 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r2.ebuild:
38 arm stable, bug #525252
39
40 16 Oct 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
41 Stable for HPPA (bug #525252).
42
43 14 Aug 2014; Samuli Suominen <ssuominen@gentoo.org> polkit-0.112-r1.ebuild,
44 polkit-0.112-r2.ebuild:
45 Fix the arch logic for HPPA (to match how IA64 and MIPS are handled in the
46 ebuild)
47
48 14 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r1.ebuild:
49 Stable for HPPA (bug #519870).
50
51 13 Aug 2014; Jeroen Roovers <jer@gentoo.org> polkit-0.112-r2.ebuild:
52 Marked ~hppa (bug #517804).
53
54 17 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
55 Stable for alpha, wrt bug #508862
56
57 14 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
58 Stable for sparc, wrt bug #508862
59
60 13 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
61 Stable for ia64, wrt bug #508862
62
63 11 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
64 Stable for ppc64, wrt bug #508862
65
66 10 May 2014; Agostino Sarubbo <ago@gentoo.org> polkit-0.112-r1.ebuild:
67 Stable for ppc, wrt bug #508862
68
69 06 Apr 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r2.ebuild:
70 Needs to be rebuilt with systemd subslot bumps
71
72 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> metadata.xml:
73 Add proper metadata for freedesktop-bugs@g.o
74
75*polkit-0.112-r2 (15 Mar 2014)
76
77 15 Mar 2014; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r2.ebuild:
78 USE="jit" to determine which pax-mark, if any, should be applied wrt #485910
79
80 11 Mar 2014; Pacho Ramos <pacho@gentoo.org> metadata.xml:
81 Cleanup due #239126
82
83 25 Feb 2014; Markus Meier <maekke@gentoo.org> polkit-0.112-r1.ebuild:
84 arm stable, bug #500758
85
86 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
87 x86 stable, bug #500758
88
89 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> polkit-0.112-r1.ebuild:
90 amd64 stable, bug #500758
91
92 28 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
93 Fix ia64 where the order of the configure options was overridden by mips,
94 thanks Arfrever
95
96 27 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
97 Because sometimes portage is stupid
98
99 24 Dec 2013; Anthony G. Basile <blueness@gentoo.org> polkit-0.112-r1.ebuild:
100 Fix dependence on spidermonkey for mips, bug #495168
101
102 23 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
103 Stable for sparc, wrt bug #484486
104
105 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
106 Stable for alpha, wrt bug #484486
107
108 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
109 Stable for ia64, wrt bug #484486
110
111 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
112 Stable for ppc64, wrt bug #484486
113
114 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
115 Stable for ppc, wrt bug #484486
116
117 22 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
118 Stable for arm, wrt bug #484486
119
120 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
121 Stable for x86, wrt bug #484486
122
123 21 Sep 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.112.ebuild:
124 Stable for amd64, wrt bug #484486
125
126 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.110-r1.ebuild,
127 -files/polkit-0.110-CVE-2013-4288.patch:
128 old
129
130*polkit-0.112-r1 (19 Sep 2013)
131
132 19 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.112-r1.ebuild,
133 polkit-0.112.ebuild:
134 -r0 is for stabilization w/ mozjs185 and -r1 is for ~arch with mozjs 17.0
135
136 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> -polkit-0.111-r1.ebuild:
137 Remove vulnerable version
138
139*polkit-0.110-r1 (19 Sep 2013)
140
141 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org>
142 +files/polkit-0.110-CVE-2013-4288.patch, +polkit-0.110-r1.ebuild:
143 Bump for CVE-2013-4288
144
145*polkit-0.112 (19 Sep 2013)
146
147 19 Sep 2013; Doug Goldstein <cardoe@gentoo.org> +polkit-0.112.ebuild:
148 Bump for CVE-2013-4288
149
150 10 Sep 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
151 polkit-0.111-r1.ebuild:
152 Stop forcing USE="consolekit systemd" for sys-auth/pambase in PDEPEND because
153 CONFIG_AUDITSYSCALL=y is not possible on every arch and the dependency was
154 always more about convinience than being strict requirement.
155
156 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> -polkit-0.111.ebuild:
157 dropped polkit-111 in favour of -r1 now that spidermonkey-17 is unmasked, as
158 per ssuominen's approval
159
160 09 Aug 2013; Ian Stakenvicius <axs@gentoo.org> polkit-0.110.ebuild,
161 polkit-0.111-r1.ebuild:
162 Adjusted deps for dev-lang/spidermonkey to ensure SLOT=0
163
164*polkit-0.111-r1 (08 Aug 2013)
165
166 08 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111-r1.ebuild:
167 Force use of dev-lang/spidermonkey:17 because automagic dependencies are bad.
168
169*polkit-0.111 (15 May 2013)
170
171 15 May 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.111.ebuild:
172 Version bump by "okias" from Freenode
173
174 19 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107-r1.ebuild,
175 -files/polkit-0.107-fallback.patch:
176 old
177
178 19 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
179 Stable for sh, wrt bug #452688
180
181 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
182 files/polkit-0.110-W_define.patch:
183 Include link to upstream bug.
184
185 12 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild,
186 +files/polkit-0.110-W_define.patch:
187 Fix missing #include <sys/wait.h> for #define's of WIFEXITED, WEXITSTATUS,
188 WIFSIGNALED and WTERMSIG (to fix building on arch "sh")
189
190 09 Mar 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
191 Stable for sparc, wrt bug #452688
192
193 03 Mar 2013; Mike Frysinger <vapier@gentoo.org> polkit-0.110.ebuild:
194 Add s390 keywords #457078 by Michael Palimaka.
195
196 23 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
197 Stable for alpha, wrt bug #452688
198
199 10 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
200 Stable for ppc64, wrt bug #452688
201
202 09 Feb 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
203 Stable for ia64, wrt bug #452688
204
205 31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.110.ebuild:
206 Stable for ppc, wrt bug #452688
207
208 29 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
209 Force USE="debug" to be disabled in dev-lang/spidermonkey to avoid asseration
210 errors as noted by _AxS_.
211
212 26 Jan 2013; Markus Meier <maekke@gentoo.org> polkit-0.110.ebuild:
213 arm stable, bug #452688
214
215 20 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
216 x86 stable wrt #452688
217
218 19 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> polkit-0.110.ebuild:
219 amd64 stable wrt #452688
220
221 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.104-r1.ebuild,
222 -polkit-0.109-r1.ebuild, -files/polkit-0.109-XAUTHORITY-fallback.patch:
223 old
224
225*polkit-0.110 (11 Jan 2013)
226
227 11 Jan 2013; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.110.ebuild:
228 Version bump.
229
230 06 Jan 2013; Raúl Porcel <armin76@gentoo.org> polkit-0.107-r1.ebuild,
231 polkit-0.109-r1.ebuild:
232 Add ~sh wrt #436668
233
234 01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> polkit-0.109-r1.ebuild:
235 Add ~ia64, wrt bug #436668
236
237 30 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
238 Stable for sparc, wrt bug #436666
239
240 29 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
241 Stable for alpha, wrt bug #436666
242
243 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.108.ebuild,
244 -polkit-0.109.ebuild:
245 old
246
247*polkit-0.109-r1 (21 Dec 2012)
248
249 21 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109-r1.ebuild,
250 +files/polkit-0.109-XAUTHORITY-fallback.patch:
251 Backport XAUTHORITY fallback support from upstream git.
252
253 19 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.108.ebuild:
254 Add ~ia64, wrt bug #436668
255
256*polkit-0.109 (19 Dec 2012)
257
258 19 Dec 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.109.ebuild:
259 Version bump. Fix PaX marking logic wrt #444446 by Maxim Kammerer
260
261 18 Dec 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
262 Stable for ia64, wrt bug #436666
263
264 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
265 stable arm, bug #436666
266
267 22 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.107.ebuild:
268 old
269
270 22 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
271 stable ppc64, bug #436666
272
273 22 Nov 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
274 Stable for x86, tested by Vincent Olivert Riera <peratu@carrosses.com>, wrt
275 bug #436666
276
277 21 Nov 2012; Anthony G. Basile <blueness@gentoo.org> polkit-0.107-r1.ebuild:
278 stable ppc, bug #436666, thanks peratu
279
280 19 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.108.ebuild:
281 Link against -lgmodule-2.0 to prevent underlinking (backported from upstream,
282 but using sed to avoid eautoreconf) wrt #443798
283
284*polkit-0.108 (18 Nov 2012)
285
286 18 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.108.ebuild:
287 Version bump.
288
289 28 Oct 2012; Naohiro Aota <naota@gentoo.org> polkit-0.104-r1.ebuild,
290 polkit-0.107-r1.ebuild, polkit-0.107.ebuild:
291 Drop ~x86-fbsd due to bug #439968.
292
293 15 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.104-r1.ebuild,
294 polkit-0.107-r1.ebuild:
295 Drop HPPA keywording (bug #438368).
296
297 15 Oct 2012; Zac Medico <zmedico@gentoo.org> polkit-0.107-r1.ebuild:
298 Set QA_MULTILIB_PATHS for bug #424423.
299
300 09 Oct 2012; Jeroen Roovers <jer@gentoo.org> polkit-0.107-r1.ebuild:
301 Marked ~hppa (bug #436668).
302
303 08 Oct 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.107-r1.ebuild:
304 Use pax-mark in src_compile() instead of src_install() for src_test() wrt
305 #423927 by "kensington" and "Nikoli". Punt bogus RESTRICT for multilib-strict
306 and emphatize it's an Portage issue instead of polkit issue in src_install()
307 message.
308
309 07 Oct 2012; Agostino Sarubbo <ago@gentoo.org> polkit-0.107-r1.ebuild:
310 Stable for amd64, wrt bug #436666
311
312*polkit-0.107-r1 (20 Sep 2012)
313
314 20 Sep 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107-r1.ebuild,
315 +files/polkit-0.107-fallback.patch:
316 Introduce upstream patch for falling back to uid 0 for authentication if list
317 of admin identities is empty.
318
319 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.105.ebuild,
320 -polkit-0.106-r7.ebuild:
321 old
322
323*polkit-0.107 (13 Jul 2012)
324
325 13 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.107.ebuild:
326 Version bump.
327
328 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r5.ebuild,
329 -polkit-0.106-r6.ebuild:
330 old
331
332 07 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r7.ebuild:
333 Remove USE="debug" because --enable/--disable-verbose-mode is no-op wrt
334 #391865 by Maksim Melnikau
335
336*polkit-0.106-r7 (02 Jul 2012)
337
338 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r7.ebuild:
339 RESTRICT="multilib-strict" since it's not compatible with the whole
340 /usr/libexec -> /usr/lib/$package migration wrt #424423. This will move
341 polkit-agent-helper-1 and polkitd back to /usr/lib/polkit-1.
342
343*polkit-0.106-r6 (01 Jul 2012)
344
345 01 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r6.ebuild:
346 Fix hardcoded path to "lib" in polkitagentsession.c for systems without the
347 /usr/lib to /usr/lib64 symlink.
348
349 30 Jun 2012; <swift@gentoo.org> polkit-0.104-r1.ebuild, polkit-0.105.ebuild,
350 polkit-0.106-r5.ebuild:
351 Adding dependency on SELinux policykit module if USE=selinux is set
352
353 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> polkit-0.106-r5.ebuild:
354 pax-mark polkitd only when spidermonkey is built with JIT enabled and only
355 'm' instead of 'mr' when version is >= 1.8.7 (by using has_version check)
356
357 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> -polkit-0.106-r2.ebuild,
358 -polkit-0.106-r3.ebuild, -polkit-0.106-r4.ebuild:
359 old
360
361*polkit-0.106-r5 (27 Jun 2012)
362
363 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r5.ebuild:
364 Revert entire unix-group:wheel experiment back to unix-user:0 because
365 PolicyKit agent(s) don't behave correctly with it wrt #423733 by Travis
366 Hansen. Revert system-local-login to system-auth for PAM errors wrt #423487
367 by Doug Goldstein.
4 368
5*polkit-0.106-r4 (27 Jun 2012) 369*polkit-0.106-r4 (27 Jun 2012)
6 370
7 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild: 371 27 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> +polkit-0.106-r4.ebuild:
8 Stop installing polkit-backend-1.pc because upstream changed 372 Stop installing polkit-backend-1.pc because upstream changed
333 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org> 697 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
334 +files/polkit-0.92-zsh-completions.patch, 698 +files/polkit-0.92-zsh-completions.patch,
335 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild, 699 +files/polkit-0.93-fix-daemon-name.patch, +polkit-0.94.ebuild,
336 +metadata.xml: 700 +metadata.xml:
337 Initial ebuild for GNOME 2.28. 701 Initial ebuild for GNOME 2.28.
338

Legend:
Removed from v.1.89  
changed lines
  Added in v.1.190

  ViewVC Help
Powered by ViewVC 1.1.20