/[gentoo-x86]/www-apps/rt/rt-3.4.2-r1.ebuild
Gentoo

Diff of /www-apps/rt/rt-3.4.2-r1.ebuild

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.7 Revision 1.8
1# Copyright 1999-2005 Gentoo Foundation 1# Copyright 1999-2005 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2 2# Distributed under the terms of the GNU General Public License v2
3# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/Attic/rt-3.4.2-r1.ebuild,v 1.7 2005/08/24 20:16:00 rl03 Exp $ 3# $Header: /var/cvsroot/gentoo-x86/www-apps/rt/Attic/rt-3.4.2-r1.ebuild,v 1.8 2005/09/11 17:49:54 rl03 Exp $
4 4
5inherit webapp eutils 5inherit webapp eutils
6 6
7IUSE="mysql postgres fastcgi apache2 lighttpd" 7IUSE="mysql postgres fastcgi apache2 lighttpd"
8 8
92 92
93 # first check if username rt exists 93 # first check if username rt exists
94 if [[ ${euser} == $(egetent passwd "${euser}" | cut -d: -f1) ]] ; then 94 if [[ ${euser} == $(egetent passwd "${euser}" | cut -d: -f1) ]] ; then
95 # check uid 95 # check uid
96 rt_uid=$(egetent passwd "${euser}" | cut -d: -f3) 96 rt_uid=$(egetent passwd "${euser}" | cut -d: -f3)
97 if `expr ${rt_uid} '<' 1000 > /dev/null`; then 97 if $(expr ${rt_uid} '<' 1000 > /dev/null); then
98 ewarn "uid of user rt is less than 1000. suexec2 will not work." 98 ewarn "uid of user rt is less than 1000. suexec2 will not work."
99 ewarn "If you want to use FastCGI, please delete the user 'rt'" 99 ewarn "If you want to use FastCGI, please delete the user 'rt'"
100 ewarn "from your system and re-emerge www-apps/rt" 100 ewarn "from your system and re-emerge www-apps/rt"
101 epause 101 epause
102 fi 102 fi
164 --with-web-user=${web} \ 164 --with-web-user=${web} \
165 --with-web-group=${web} 165 --with-web-group=${web}
166 166
167 # check for missing deps and ask to report if something is broken 167 # check for missing deps and ask to report if something is broken
168 /usr/bin/perl ./sbin/rt-test-dependencies --verbose \ 168 /usr/bin/perl ./sbin/rt-test-dependencies --verbose \
169 `use_with mysql` \ 169 $(use_with mysql) \
170 `use_with postgres pg` > ${T}/t 170 $(use_with postgres pg) > ${T}/t
171 if grep -q "MISSING" ${T}/t; then 171 if grep -q "MISSING" ${T}/t; then
172 ewarn "Missing Perl dependency!" 172 ewarn "Missing Perl dependency!"
173 ewarn 173 ewarn
174 cat ${T}/t 174 cat ${T}/t
175 ewarn 175 ewarn

Legend:
Removed from v.1.7  
changed lines
  Added in v.1.8

  ViewVC Help
Powered by ViewVC 1.1.20