/[gentoo]/xml/htdocs/doc/en/handbook/hb-install-ppc64-bootloader.xml
Gentoo

Diff of /xml/htdocs/doc/en/handbook/hb-install-ppc64-bootloader.xml

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

Revision 1.22 Revision 1.24
2<!DOCTYPE sections SYSTEM "/dtd/book.dtd"> 2<!DOCTYPE sections SYSTEM "/dtd/book.dtd">
3 3
4<!-- The content of this document is licensed under the CC-BY-SA license --> 4<!-- The content of this document is licensed under the CC-BY-SA license -->
5<!-- See http://creativecommons.org/licenses/by-sa/2.5 --> 5<!-- See http://creativecommons.org/licenses/by-sa/2.5 -->
6 6
7<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/handbook/hb-install-ppc64-bootloader.xml,v 1.22 2006/01/20 10:52:15 neysx Exp $ --> 7<!-- $Header: /var/cvsroot/gentoo/xml/htdocs/doc/en/handbook/hb-install-ppc64-bootloader.xml,v 1.24 2006/03/17 10:31:53 neysx Exp $ -->
8 8
9<sections> 9<sections>
10 10
11<version>2.7</version> 11<version>2.9</version>
12<date>2006-01-20</date> 12<date>2006-03-17</date>
13 13
14<section> 14<section>
15<title>Making your Choice</title> 15<title>Making your Choice</title>
16<subsection> 16<subsection>
17<title>Introduction</title> 17<title>Introduction</title>
37<subsection> 37<subsection>
38<title>Introduction</title> 38<title>Introduction</title>
39<body> 39<body>
40 40
41<impo> 41<impo>
42You have to use yaboot-static instead of yaboot, because yaboot won't 42If you are using a 64-bit userland, you must use the <c>yaboot-static</c>
43compile on PPC64. 43package because yaboot cannot be compiled as a 64-bit application. The 32-bit
44userlands should use the regular yaboot package.
44</impo> 45</impo>
45 46
46<p> 47<p>
47There are two ways to configure yaBoot for your system. You can use the 48There are two ways to configure yaBoot for your system. You can use the
48new and improved <c>yabootconfig</c> included with 49new and improved <c>yabootconfig</c> included with
91yaboot-static</c>. This is necessary as the latest version will be available via 92yaboot-static</c>. This is necessary as the latest version will be available via
92Portage, but it may not have made it into the stage files. 93Portage, but it may not have made it into the stage files.
93</p> 94</p>
94 95
95<pre caption = "Installing yaboot-static"> 96<pre caption = "Installing yaboot-static">
97<comment>(For 64-bit users)</comment>
96# <i>emerge --update yaboot-static</i> 98# <i>emerge --update yaboot-static</i>
99
100<comment>(For 32-bit users)</comment>
101# <i>emerge yaboot</i>
97</pre> 102</pre>
98 103
99<p> 104<p>
100Now run <c>yabootconfig</c>. The program will run and it will confirm 105Now run <c>yabootconfig</c>. The program will run and it will confirm
101the location of the bootstrap partition. Type <c>Y</c> if it is correct. If 106the location of the bootstrap partition. Type <c>Y</c> if it is correct. If
126First make sure you have the latest <c>yaboot-static</c> installed on your 131First make sure you have the latest <c>yaboot-static</c> installed on your
127system: 132system:
128</p> 133</p>
129 134
130<pre caption = "Installing yaboot"> 135<pre caption = "Installing yaboot">
136<comment>(For 64-bit users)</comment>
131# <i>emerge --update yaboot-static</i> 137# <i>emerge --update yaboot-static</i>
138
139<comment>(For 32-bit users)</comment>
140# <i>emerge yaboot</i>
132</pre> 141</pre>
133 142
134<p> 143<p>
135Below you find a completed <path>yaboot.conf</path> file. Alter it at 144Below you find a completed <path>yaboot.conf</path> file. Alter it at
136will. 145will.
232 241
233<pre caption="yaboot.conf for IBM hardware"> 242<pre caption="yaboot.conf for IBM hardware">
234device=disk: 243device=disk:
235partition=2 244partition=2
236root=/dev/sda2 245root=/dev/sda2
237default=2.6.12-gentoo-r10 246default=linux
238timeout=50 247timeout=50
239 248
240image=/boot/kernel-2.6.12-gentoo-r10 249image=/boot/kernel-2.6.12-gentoo-r10
241 label=Linux 250 label=linux
242 append="console=ttyS0,9600" 251 append="console=ttyS0,9600"
243 read-only 252 read-only
244</pre> 253</pre>
245 254
246<p> 255<p>

Legend:
Removed from v.1.22  
changed lines
  Added in v.1.24

  ViewVC Help
Powered by ViewVC 1.1.20