/[linux-patches]/genpatches-2.6/tags/2.6.15-5/1017_2_elevator-as-back-compatibility.patch
Gentoo

Contents of /genpatches-2.6/tags/2.6.15-5/1017_2_elevator-as-back-compatibility.patch

Parent Directory Parent Directory | Revision Log Revision Log


Revision 291 - (show annotations) (download)
Tue Jan 31 20:13:37 2006 UTC (12 years, 7 months ago) by dsd
File size: 1362 byte(s)
2.6.15-5 release
1 From stable-bounces@linux.kernel.org Mon Jan 16 22:19:55 2006
2 Message-Id: <200601170615.k0H6FDZ6028782@shell0.pdx.osdl.net>
3 To: torvalds@osdl.org
4 From: akpm@osdl.org
5 Date: Mon, 16 Jan 2006 22:14:55 -0800
6 Cc: nickpiggin@yahoo.com.au, axboe@suse.de, 76306.1226@compuserve.com, stable@kernel.org
7 Subject: [PATCH] elevator=as back-compatibility
8
9 From: Chuck Ebbert <76306.1226@compuserve.com>
10
11 As of 2.6.15 you need to use "anticipatory" instead of "as". Fix that up
12 so that `elevator=as' still works.
13
14 Signed-off-by: Chuck Ebbert <76306.1226@compuserve.com>
15 Cc: Nick Piggin <nickpiggin@yahoo.com.au>
16 Cc: Jens Axboe <axboe@suse.de>
17 Cc: <stable@kernel.org>
18 Signed-off-by: Andrew Morton <akpm@osdl.org>
19 Signed-off-by: Chris Wright <chrisw@sous-sol.org>
20 Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
21 ---
22 block/elevator.c | 7 +++++++
23 1 file changed, 7 insertions(+)
24
25 --- linux-2.6.15.1.orig/block/elevator.c
26 +++ linux-2.6.15.1/block/elevator.c
27 @@ -150,6 +150,13 @@ static void elevator_setup_default(void)
28 if (!chosen_elevator[0])
29 strcpy(chosen_elevator, CONFIG_DEFAULT_IOSCHED);
30
31 + /*
32 + * Be backwards-compatible with previous kernels, so users
33 + * won't get the wrong elevator.
34 + */
35 + if (!strcmp(chosen_elevator, "as"))
36 + strcpy(chosen_elevator, "anticipatory");
37 +
38 /*
39 * If the given scheduler is not available, fall back to no-op.
40 */

  ViewVC Help
Powered by ViewVC 1.1.20