aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2020-01-28 12:42:15 -0600
committerJory Pratt <anarchy@gentoo.org>2020-01-28 12:42:15 -0600
commit7f34e50ef9126f62b6a5ae8e34b7b5e7c29a014e (patch)
treebca642dae0be3b625da2ed5f9a36463ffd64f3ed
parentx11-wm/i3: adjust cairo dep (diff)
downloadmusl-7f34e50ef9126f62b6a5ae8e34b7b5e7c29a014e.tar.gz
musl-7f34e50ef9126f62b6a5ae8e34b7b5e7c29a014e.tar.bz2
musl-7f34e50ef9126f62b6a5ae8e34b7b5e7c29a014e.zip
app-office/libreoffice: Update to latest stable
Package-Manager: Portage-2.3.86, Repoman-2.3.20 Signed-off-by: Jory Pratt <anarchy@gentoo.org>
-rw-r--r--app-office/libreoffice/Manifest4
-rw-r--r--app-office/libreoffice/files/libreoffice-6.3.3.2-mysql-connector-c-8.patch45
-rw-r--r--app-office/libreoffice/files/libreoffice-6.3.4.2-poppler-0.83.patch72
-rw-r--r--app-office/libreoffice/libreoffice-6.3.4.2.ebuild (renamed from app-office/libreoffice/libreoffice-6.2.5.2.ebuild)37
-rw-r--r--app-office/libreoffice/metadata.xml1
5 files changed, 139 insertions, 20 deletions
diff --git a/app-office/libreoffice/Manifest b/app-office/libreoffice/Manifest
index a5b6cde..1083824 100644
--- a/app-office/libreoffice/Manifest
+++ b/app-office/libreoffice/Manifest
@@ -3,6 +3,6 @@ DIST 185d60944ea767075d27247c3162b3bc-unowinreg.dll 12288 BLAKE2B c067f60d0ee325
DIST 35c94d2df8893241173de1d16b6034c0-swingExSrc.zip 9796 BLAKE2B a30b0225313b23092bc57ccd989f26ea04a323dcb17a0ea8baaa6a21b5d5e2b6e29fcae9d18ecd043073030e104ad56c86a115760590f57eda86c22c9fe478b0 SHA512 4a48f1e32907fb2dee601cda3cd7a0d7198b2d51f2a572b647f1e93f901fd511eef3567676e52dfb1723a2cdfbc01f2015ca0bb22903b0bc1476dd618cc9aa8a
DIST 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip 1521926 BLAKE2B d2769842c180997055648a8b1a33cc89988b74628bad8aa012242e0c1afa5b5b8568323c107187072207ee69bd841ba4ca3bbfe27ef65223ddc729d1a1aa6590 SHA512 ec5ae23c8fe2f5efc377f7a9665039afadf28b4d8f2791379296766a5fbc9a3bf7548f9b0e3b3b07762229ec733a92ccbb69791ee0318c9c6f78f8e847253d3f
DIST a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip 23150 BLAKE2B 51db6bd90585b13857ecb494c805c9fb6874e1e65d7aee73d23e1716670836a14b376bcca810f96fd55b0ed653b2660a268030f246c822cbb04f867ef763a3b3 SHA512 2d3835f7ac356805025cafedcad97faa48d0f5da386e6ac7b7451030059df8e2fdb0861ade07a576ebf9fb5b88a973585ab0437944b06aac9289d6898ba8586a
-DIST libreoffice-6.2.5.2.tar.xz 215008848 BLAKE2B 5dd1ef185820944816e01c8ed6a7873a5a8fe6f7f4b41fad279729970d85ff868f51ed573e8b3d0a554ffd1f8e295b6ff2e493e7f7250f8cb1c7c2a40115abf4 SHA512 b46b6731c415ab354ad7d876cb8905cb9eae2ca71639abf049ea7f5930601c957cc0eb04a2cd06949073ba5e94778ecdb449692ed8bbfbd95b05f6e7980d8d10
+DIST libreoffice-6.3.4.2.tar.xz 225632492 BLAKE2B 587fe7e6298ded60fa08963f572733eb8e387c00b428201bb6f1de7eddcf9d9ee97438231ed3f961bd22628bde0fd9dfeacb63febdc566cde781bcebb9c9a71d SHA512 2ed687ae805da36635419729066a2924f1e38a6b0f8d2692c42b366450a261012adfcd8a5d7915d9cfd292d07519fc32c596cdb56d7be6b12a49618b18d6f3d2
DIST libreoffice-branding-gentoo-0.8.tar.xz 151568 BLAKE2B f03c7ddeb53c5ca3fd23401679601fcf2c4037ba17be4eb7b784c7ce7ebb71a24b8ab4aac8b7da8c6b1f14dd23bc1294ba85ff4f70ad271fb4ee3c5372e10883 SHA512 785031a699b1d1895ce4b50ffc3ddf645f3a0ef9acdf37facfd18cf75db9484cb8f53a50abb63d6006ead76a80b6ff5aa99661063245ebb84bd64013d713de7f
-DIST libreoffice-help-6.2.5.2.tar.xz 13023680 BLAKE2B f1f3a03104c1270e59f2b9130a29e1fbc99a9bf76b2bf4cedef8dc61487c9a2036f143501ad7fcd0c056c8b72446305b7a4ca9a719b11200ade5feca35e5e7ea SHA512 14f964161bd827a5846ec667ae1dac80d1485450e172da44010103e31f3872df62595e8b1b1d45c720caac9256d2adaf8f5a0bb80d059d35f1c560b533eb764c
+DIST libreoffice-help-6.3.4.2.tar.xz 13191636 BLAKE2B c1696efa0ec9fef9dbcc0c0388de8a384484af1453d200e08820ba910cdcb65638b189566a19868281fd1777213812fde06adb07c1a662302eea1d0a791ff5a0 SHA512 8c74c82c7d73adb1523300d1f7500769f5a623fdba60b440a63c122cbfeb631a6a34ecbcb115b0154a6957be1918306f7d0c1f465030f8e8cfd5c9a1acad17c9
diff --git a/app-office/libreoffice/files/libreoffice-6.3.3.2-mysql-connector-c-8.patch b/app-office/libreoffice/files/libreoffice-6.3.3.2-mysql-connector-c-8.patch
new file mode 100644
index 0000000..5fa7b34
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.3.3.2-mysql-connector-c-8.patch
@@ -0,0 +1,45 @@
+From 5917ba8bc645a2b105ec089101b8a664481b5b61 Mon Sep 17 00:00:00 2001
+From: Peter Levine <plevine457@gmail.com>
+Date: Thu, 17 Oct 2019 23:08:57 -0400
+Subject: Fix building against MySQL Connector/C 8
+
+In MySQL Connector/C 8, my_bool is replaced by bool. It was
+previously defined as char. When building against
+MySQL Connector/C 8, this leads to type punning build errors.
+Redefine affected members of struct BindMetaData as bool if using
+version 8 of greater. Otherwise, default to char.
+
+Change-Id: If12b975d95afae86502867cb334cb4195802f91d
+Reviewed-on: https://gerrit.libreoffice.org/81002
+Reviewed-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
+Tested-by: Samuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>
+---
+ .../source/drivers/mysqlc/mysqlc_preparedstatement.hxx | 10 ++++++++--
+ 1 file changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx b/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx
+index 1df2c70..3450473 100644
+--- a/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx
++++ b/connectivity/source/drivers/mysqlc/mysqlc_preparedstatement.hxx
+@@ -39,11 +39,17 @@ using ::com::sun::star::uno::Reference;
+ using ::com::sun::star::uno::RuntimeException;
+ using ::com::sun::star::uno::Type;
+
++#if defined MYSQL_VERSION_ID && (MYSQL_VERSION_ID >= 80000) && !defined MARIADB_BASE_VERSION
++using my_bool = bool;
++#else
++using my_bool = char;
++#endif
++
+ struct BindMetaData
+ {
+- char is_null = 0;
++ my_bool is_null = 0;
+ unsigned long length = 0;
+- char error = 0;
++ my_bool error = 0;
+ };
+
+ typedef ::cppu::ImplHelper5<css::sdbc::XPreparedStatement, css::sdbc::XParameters,
+--
+cgit v1.1
diff --git a/app-office/libreoffice/files/libreoffice-6.3.4.2-poppler-0.83.patch b/app-office/libreoffice/files/libreoffice-6.3.4.2-poppler-0.83.patch
new file mode 100644
index 0000000..d5697f2
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.3.4.2-poppler-0.83.patch
@@ -0,0 +1,72 @@
+From 9065cd8d9a19864f6b618f2dc10daf577badd9ee Mon Sep 17 00:00:00 2001
+From: Martin Milata <martin@martinmilata.cz>
+Date: Wed, 4 Dec 2019 02:37:40 +0100
+Subject: Fix build with poppler-0.83
+
+Change-Id: I7a3684932b8f9c403a3368b42fa4d8039c67f1a9
+Reviewed-on: https://gerrit.libreoffice.org/84384
+Tested-by: Jenkins
+Reviewed-by: Michael Stahl <michael.stahl@cib.de>
+---
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 7 +++++++
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
+ sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx | 4 ++++
+ 3 files changed, 15 insertions(+)
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index 26048177e87d..e9c2a407c279 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -491,11 +491,18 @@ void PDFOutDev::writeFontFile( GfxFont* gfxFont ) const
+ gfree(pBuf);
+ }
+
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++void PDFOutDev::printPath( const GfxPath* pPath )
++#else
+ void PDFOutDev::printPath( GfxPath* pPath )
++#endif
+ {
+ int nSubPaths = pPath ? pPath->getNumSubpaths() : 0;
+ for( int i=0; i<nSubPaths; i++ )
+ {
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++ const
++#endif
+ GfxSubpath* pSub = pPath->getSubpath( i );
+ const int nPoints = pSub->getNumPoints();
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index 02f6b59f6f15..2e7d2186f9a1 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -149,7 +149,11 @@ namespace pdfi
+
+ int parseFont( long long nNewId, GfxFont* pFont, GfxState* state ) const;
+ void writeFontFile( GfxFont* gfxFont ) const;
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++ static void printPath( const GfxPath* pPath );
++#else
+ static void printPath( GfxPath* pPath );
++#endif
+
+ public:
+ explicit PDFOutDev( PDFDoc* pDoc );
+diff --git a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+index 42178b650cdd..b1a54bd09c5f 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx
+@@ -68,7 +68,11 @@ int main(int argc, char **argv)
+ }
+
+ // read config file
++#if POPPLER_CHECK_VERSION(0, 83, 0)
++ globalParams = std::make_unique<GlobalParams>();
++#else
+ globalParams = new GlobalParams();
++#endif
+ globalParams->setErrQuiet(true);
+ #if defined(_MSC_VER)
+ globalParams->setupBaseFonts(nullptr);
+--
+cgit v1.2.1
diff --git a/app-office/libreoffice/libreoffice-6.2.5.2.ebuild b/app-office/libreoffice/libreoffice-6.3.4.2.ebuild
index 5994e6d..b0ff46d 100644
--- a/app-office/libreoffice/libreoffice-6.2.5.2.ebuild
+++ b/app-office/libreoffice/libreoffice-6.3.4.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+),xml"
MY_PV="${PV/_alpha/.alpha}"
@@ -63,7 +63,7 @@ unset ADDONS_SRC
LO_EXTS="nlpsolver scripting-beanshell scripting-javascript wiki-publisher"
IUSE="accessibility bluetooth +branding coinmp +cups dbus debug eds firebird
-googledrive gstreamer +gtk gtk2 kde ldap +mariadb odk pdfimport postgres test vlc
+googledrive gstreamer +gtk gtk2 kde ldap +mariadb odk pdfimport postgres test
$(printf 'libreoffice_extensions_%s ' ${LO_EXTS})"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
@@ -74,6 +74,8 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}
libreoffice_extensions_wiki-publisher? ( java )
"
+RESTRICT="!test? ( test )"
+
LICENSE="|| ( LGPL-3 MPL-1.1 )"
SLOT="0"
[[ ${MY_PV} == *9999* ]] || \
@@ -109,7 +111,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=app-text/libwps-0.4
app-text/mythes
>=dev-cpp/clucene-2.3.3.4-r2
- =dev-cpp/libcmis-0.5*
+ >=dev-cpp/libcmis-0.5.2
dev-db/unixODBC
dev-lang/perl
dev-libs/boost:=[nls]
@@ -125,7 +127,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/nspr
dev-libs/nss
>=dev-libs/redland-1.0.16
- >=dev-libs/xmlsec-1.2.24[nss]
+ >=dev-libs/xmlsec-1.2.28[nss]
media-gfx/fontforge
media-gfx/graphite2
media-libs/fontconfig
@@ -184,8 +186,8 @@ COMMON_DEPEND="${PYTHON_DEPS}
kde? (
dev-qt/qtcore:5
dev-qt/qtgui:5
- dev-qt/qtx11extras:5
dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
kde-frameworks/kconfig:5
kde-frameworks/kcoreaddons:5
kde-frameworks/ki18n:5
@@ -208,7 +210,7 @@ DEPEND="${COMMON_DEPEND}
>=dev-libs/libatomic_ops-7.2d
dev-perl/Archive-Zip
>=dev-util/cppunit-1.14.0
- >=dev-util/gperf-3
+ >=dev-util/gperf-3.1
>=dev-util/mdds-1.4.1:1=
media-libs/glm
sys-devel/ucpp
@@ -234,7 +236,6 @@ RDEPEND="${COMMON_DEPEND}
|| ( x11-misc/xdg-utils kde-plasma/kde-cli-tools )
java? ( >=virtual/jre-1.6 )
kde? ( kde-frameworks/breeze-icons:* )
- vlc? ( media-video/vlc )
"
if [[ ${MY_PV} != *9999* ]] && [[ ${PV} != *_* ]]; then
PDEPEND="=app-office/libreoffice-l10n-$(ver_cut 1-2)*"
@@ -245,8 +246,6 @@ else
fi
PATCHES=(
- # master branch
- "${FILESDIR}/${PN}-6.2-ldap-optional.patch"
# "${WORKDIR}"/${PATCHSET/.tar.xz/}
# not upstreamable stuff
@@ -254,6 +253,10 @@ PATCHES=(
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
+ # master branch
+ "${FILESDIR}/${PN}-6.3.3.2-mysql-connector-c-8.patch" # bug #692422
+ "${FILESDIR}/${P}-poppler-0.83.patch"
+
# musl compatibility by AlpineLinux
"${FILESDIR}/${PN}-6.1.4.2-linux-musl.patch"
"${FILESDIR}/${PN}-6.1.4.2-musl-fix-execinfo.patch"
@@ -275,8 +278,11 @@ _check_reqs() {
}
pkg_pretend() {
- use java || \
- ewarn "If you plan to use Base application you should enable java or you will get various crashes."
+ if ! use java && ! use firebird; then
+ ewarn "If you plan to use Base application you must enable either firebird or java."
+ fi
+
+ use java || ewarn "Without java, several wizards are not going to be available."
if has_version "<app-office/libreoffice-5.3.0[firebird]"; then
ewarn "Firebird has been upgraded to version 3. It is unable to read back Firebird 2.5 data, so"
@@ -416,10 +422,12 @@ src_configure() {
--disable-epm
--disable-fetch-external
--disable-gstreamer-0-10
+ --disable-gtk3-kde5
--disable-online-update
--disable-openssl
--disable-pdfium
--disable-report-builder
+ --disable-vlc
--with-build-version="${gentoo_buildid}"
--enable-extension-integration
--with-external-dict-dir="${EPREFIX}/usr/share/myspell"
@@ -454,7 +462,6 @@ src_configure() {
$(use_enable odk)
$(use_enable pdfimport)
$(use_enable postgres postgresql-sdbc)
- $(use_enable vlc)
$(use_with accessibility lxml)
$(use_with coinmp system-coinmp)
$(use_with googledrive gdrive-client-id ${google_default_client_id})
@@ -463,10 +470,6 @@ src_configure() {
$(use_with odk doxygen)
)
- if use gtk && use kde; then
- myeconfargs+=( --enable-gtk3-kde5 )
- fi
-
if use eds || use gtk; then
myeconfargs+=( --enable-dconf --enable-gio )
else
diff --git a/app-office/libreoffice/metadata.xml b/app-office/libreoffice/metadata.xml
index 6b51466..38a66bc 100644
--- a/app-office/libreoffice/metadata.xml
+++ b/app-office/libreoffice/metadata.xml
@@ -17,6 +17,5 @@ version</longdescription>
<flag name="mariadb">Prefer mariadb connector over mysql connector</flag>
<flag name="odk">Build the Office Development Kit</flag>
<flag name="pdfimport">Enable PDF import via the Poppler library</flag>
- <flag name="vlc">Use <pkg>media-video/vlc</pkg> for video embedding</flag>
</use>
</pkgmetadata>