summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2017-09-25 16:46:14 +0200
committerMichael Haubenwallner <haubi@gentoo.org>2017-09-25 16:46:14 +0200
commit7d6dc109770f711173e8538d907675de5408407a (patch)
tree065e5b3423c1794f6af1684e67a5c2526e74b5e0 /sys-libs
parentsys-libs/db-6.0.35-r1: fix for x86-winnt (diff)
downloadprefix-7d6dc109770f711173e8538d907675de5408407a.tar.gz
prefix-7d6dc109770f711173e8538d907675de5408407a.tar.bz2
prefix-7d6dc109770f711173e8538d907675de5408407a.zip
sys-libs/db-5.3.28-r3: fix for x86-winnt
Package-Manager: Portage-2.3.8-prefix, Repoman-2.3.3
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/db-5.3.28-r3.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sys-libs/db/db-5.3.28-r3.ebuild b/sys-libs/db/db-5.3.28-r3.ebuild
index 13ffc4a8f2..695ebf4f91 100644
--- a/sys-libs/db/db-5.3.28-r3.ebuild
+++ b/sys-libs/db/db-5.3.28-r3.ebuild
@@ -27,7 +27,7 @@ done
LICENSE="Sleepycat"
SLOT="5.3"
-KEYWORDS="~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
IUSE="doc java cxx tcl test"
REQUIRED_USE="test? ( tcl )"
@@ -95,6 +95,8 @@ src_prepare() {
# Needed when compiling with clang
epatch "${FILESDIR}"/${PN}-5.1.29-rename-atomic-compare-exchange.patch
+ epatch "${FILESDIR}"/${PN}-6.0.35-winnt.patch
+
# Upstream release script grabs the dates when the script was run, so lets
# end-run them to keep the date the same.
export REAL_DB_RELEASE_DATE="$(awk \
@@ -170,6 +172,14 @@ multilib_src_configure() {
myconf+=(--disable-tcl )
fi
+ if [[ ${CHOST} == *-winnt* ]]; then
+ # this one should really sound --enable-windows, but
+ # seems the db devs only support mingw ... doesn't enable
+ # anything too specific to mingw.
+ myconf+=(--enable-mingw)
+ myconf+=(--with-mutex=win32)
+ fi
+
# sql_compat will cause a collision with sqlite3
# --enable-sql_compat
# Don't --enable-sql* because we don't want to use bundled sqlite.