summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2021-02-01 10:43:00 -0500
committerBrian Evans <grknight@gentoo.org>2021-02-01 10:43:00 -0500
commit16f87dc58f73087fd53ed669e6d2f7eee142116c (patch)
treed62daca0b0799f188038f35d716ae09691c2d0af /dev-php/pecl-http/pecl-http-3.2.4.ebuild
parentdev-python/pytest-xdist: amd64/arm64/arm/hppa/ppc64/ppc/sparc/x86 stable (ALL... (diff)
downloadgentoo-16f87dc58f73087fd53ed669e6d2f7eee142116c.tar.gz
gentoo-16f87dc58f73087fd53ed669e6d2f7eee142116c.tar.bz2
gentoo-16f87dc58f73087fd53ed669e6d2f7eee142116c.zip
dev-php/pecl-http: Drop libressl from cURL options
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-http/pecl-http-3.2.4.ebuild')
-rw-r--r--dev-php/pecl-http/pecl-http-3.2.4.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-php/pecl-http/pecl-http-3.2.4.ebuild b/dev-php/pecl-http/pecl-http-3.2.4.ebuild
index f4816f1ac8c3..0a717e5377db 100644
--- a/dev-php/pecl-http/pecl-http-3.2.4.ebuild
+++ b/dev-php/pecl-http/pecl-http-3.2.4.ebuild
@@ -20,7 +20,7 @@ KEYWORDS="~amd64 ~x86"
DESCRIPTION="Extended HTTP Support for PHP"
LICENSE="BSD-2 MIT"
SLOT="7"
-IUSE="ssl curl_ssl_gnutls curl_ssl_libressl curl_ssl_nss +curl_ssl_openssl"
+IUSE="ssl curl_ssl_gnutls curl_ssl_nss +curl_ssl_openssl"
COMMON_DEPEND="app-arch/brotli:=
dev-libs/libevent
@@ -28,12 +28,12 @@ COMMON_DEPEND="app-arch/brotli:=
>=dev-php/pecl-raphf-2.0.1:7[php_targets_php7-3(-)?,php_targets_php7-4(-)?]
net-dns/libidn2
sys-libs/zlib
- ssl? ( net-misc/curl[ssl,curl_ssl_gnutls=,curl_ssl_libressl=,curl_ssl_nss=,curl_ssl_openssl=] )
+ ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_nss(-)=,curl_ssl_openssl(-)=] )
!ssl? ( net-misc/curl[-ssl] )
"
DEPEND="
- php_targets_php7-3? ( ${COMMON_DEPEND} dev-lang/php:7.3[hash,session,iconv] )
- php_targets_php7-4? ( ${COMMON_DEPEND} dev-lang/php:7.4[session,iconv] )"
+ php_targets_php7-3? ( ${COMMON_DEPEND} dev-lang/php:7.3[hash(+),session(-),iconv(-)] )
+ php_targets_php7-4? ( ${COMMON_DEPEND} dev-lang/php:7.4[session(-),iconv(-)] )"
RDEPEND="${DEPEND}
php_targets_php8-0? ( dev-php/pecl-http:8[php_targets_php8-0(-)] )"